Actions

Difference between revisions of "Sonic Advance 2/Bugs"

From Sonic Retro

(The infamous broken multiplayer mode bug. It resurfaced on GBARunner2.)
 
(General bugs: Rename to emulator bugs, since this can't happen on HW.)
Line 1: Line 1:
==General bugs==
+
==Emulator bugs==
 
===Broken Multiplayer Mode on Startup===
 
===Broken Multiplayer Mode on Startup===
 
Sonic Advance 2 uses some of the link cable registers to determine if it's running in multiplayer mode. Some older emulators don't implement this correctly, which can result in multiplayer mode loading on startup with blank player slates. Soft-resetting ({{A}}+{{B}}+{{Select}}+{{Start}}) can usually get to the main title screen.
 
Sonic Advance 2 uses some of the link cable registers to determine if it's running in multiplayer mode. Some older emulators don't implement this correctly, which can result in multiplayer mode loading on startup with blank player slates. Soft-resetting ({{A}}+{{B}}+{{Select}}+{{Start}}) can usually get to the main title screen.

Revision as of 17:35, 13 January 2017

Emulator bugs

Broken Multiplayer Mode on Startup

Sonic Advance 2 uses some of the link cable registers to determine if it's running in multiplayer mode. Some older emulators don't implement this correctly, which can result in multiplayer mode loading on startup with blank player slates. Soft-resetting (A+B+Select+Start) can usually get to the main title screen.


Sonic Advance 2
SonicAdvance2 title.png

Main page
Maps


Manuals
Magazine articles


Development
Hidden content
Bugs

show;hide

</div>